Re: [Lazarus] AggPas does not work

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] AggPas does not work

Paul van Helden
2010/8/16 Alexander Klenin <[hidden email]>
I tried AggPas examples under Windows, and found that:
1) AggPasInLCLDemo1 does not compile -- need to remove $include from
the project file.
2) After that, it displays garbage -- see attached screenshot.
I guess that there is some problem with conversion to a native bitmap.
Any help with this?

AggPas demos still display garbage. Windows, latest snapshot of 0.9.29.
 
--
Alexander S. Klenin

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus



--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] AggPas does not work

Mattias Gaertner
On Thu, 3 Feb 2011 18:32:32 +0200
Paul van Helden <[hidden email]> wrote:

> 2010/8/16 Alexander Klenin <[hidden email]>
>
> > I tried AggPas examples under Windows, and found that:
> > 1) AggPasInLCLDemo1 does not compile -- need to remove $include from
> > the project file.
> > 2) After that, it displays garbage -- see attached screenshot.
> > I guess that there is some problem with conversion to a native bitmap.
> > Any help with this?
> >
> > AggPas demos still display garbage. Windows, latest snapshot of 0.9.29.

Maybe related: The 64bit support is not yet complete.

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] AggPas does not work

Paul van Helden
On Thu, Feb 3, 2011 at 7:44 PM, Mattias Gaertner <[hidden email]> wrote:
On Thu, 3 Feb 2011 18:32:32 +0200
Paul van Helden <[hidden email]> wrote:

> 2010/8/16 Alexander Klenin <[hidden email]>
>
> > I tried AggPas examples under Windows, and found that:
> > 1) AggPasInLCLDemo1 does not compile -- need to remove $include from
> > the project file.
> > 2) After that, it displays garbage -- see attached screenshot.
> > I guess that there is some problem with conversion to a native bitmap.
> > Any help with this?
> >
> > AggPas demos still display garbage. Windows, latest snapshot of 0.9.29.

Maybe related: The 64bit support is not yet complete.

I tried it on 32 bit Windows 7.

Paul.

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus


--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] AggPas does not work

Graeme Geldenhuys
In reply to this post by Paul van Helden
On Thursday, 3 February 2011, Paul van Helden <> wrote:
>
> AggPas demos still display garbage. Windows, latest snapshot of 0.9.29.


I recently filed a bug report on that as well. I used Ubuntu Linux
10.04.1 (64bit). I could compile the demos, but when I tried to run
them they instantly threw AV's and crashed out.

Graeme.


--
Regards,
  - Graeme -


_______________________________________________
fpGUI - a cross-platform Free Pascal GUI toolkit
http://fpgui.sourceforge.net

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus