Missing components in component palette

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing components in component palette

leledumbo
Administrator
I just updated my lazarus today (r47247) and I found that the component palette misses a lot of components. The appearing components are random, though. Some tab has 3, the other maybe 2, some other may be complete or even there are some that are totally has no components (but the tab is there). Is this another palette reordering issue?
Reply | Threaded
Open this post in threaded view
|

Re: Missing components in component palette

leledumbo
Administrator
There's a cute section in my environmenoptions.xml that might be responsible for this:
component-palette-options.png
Removing the whole section fixes it.
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

Juha Manninen
On Fri, Dec 26, 2014 at 7:59 AM, leledumbo <[hidden email]> wrote:
> There's a cute section in my environmenoptions.xml that might be responsible
> for this:
> component-palette-options.png
> <http://free-pascal-lazarus.989080.n3.nabble.com/file/n4039904/component-palette-options.png>
> Removing the whole section fixes it.

Yes, removing it was the right choice but how did this configuration
happen? There should never be visible tabs without components. A tab
without components is hidden.
Did you test the reordering while a DataModule was active? It is not
recommended because then the filtering is active. Maybe this must be
changed in the configuration GUI later, now it is kind of a feature.

The only know bug in palette reordering is related to LCL-QT. See the
mail thread "Alternative component palette layout" for details.
Can you import the "modern" layout without problems?

Juha

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

leledumbo
Administrator
> Yes, removing it was the right choice but how did this configuration
happen? There should never be visible tabs without components. A tab
without components is hidden.

I really have no idea... probably a left over from... I don't know, before this update, my component palette was fully displayed.

> Did you test the reordering while a DataModule was active?

Nope, I didn't reorder the components at all. I let the IDE does that.

> Can you import the "modern" layout without problems?

Umm... I can't see the import button... tools-options-environment-componentpalette.png
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

Giuliano Colla

Il 26/12/2014 10:43, leledumbo ha scritto:
> [...]
> Umm... I can't see the import button...
> tools-options-environment-componentpalette.png
> <http://free-pascal-lazarus.989080.n3.nabble.com/file/n4039906/tools-options-environment-componentpalette.png>
>

Did you try widening the window (making it higher)?
The "import" and "export" buttons are below the "add" and "restore"
buttons which are the last visible buttons in your image.

Giuliano


--
Giuliano Colla

Project planning question: when it's 90% done, are we halfway or not yet?


--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

leledumbo
Administrator
> Did you try widening the window (making it higher)?
The "import" and "export" buttons are below the "add" and "restore"
buttons which are the last visible buttons in your image.

Yes, even full screen: tools-options-componentpalette-fullscreen.png
This is on a standard 1366x768 notebook screen, widgetset is Qt.
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

Juha Manninen
In reply to this post by Giuliano Colla
On Fri, Dec 26, 2014 at 12:34 PM, Giuliano Colla
<[hidden email]> wrote:
> Did you try widening the window (making it higher)?
> The "import" and "export" buttons are below the "add" and "restore" buttons
> which are the last visible buttons in your image.

No Giuliano, the anchors are working correctly, I tested it.
Only the Pages ListBox is resized, the buttons move together with the
window's bottom edge.
A clean rebuild may help. If it doesn't then I have no ideas.

Juha

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Missing components in component palette

leledumbo
Administrator
> A clean rebuild may help. If it doesn't then I have no ideas.

Sorry, I was on 47056 because I thought it was a regression in 47247. Now it appears after svn up again.

For Giuliano, yes it works. I don't test thoroughly, but at least switching tabs work, no components seem missing. Restore default also works.