[Lazarus] startup problem

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] startup problem

Xiangrong Fang
Hi,

While I start lazarus it pops up a box saying:

Package: "LCLBase 1.0"
Unit Name: "RegisterLCL"
Unit not found: "RegisterLCL"

This happens on Linux x64 platform and on several recent releases of lazarus 0.9.31 (e.g.  svn daily snapshot 20110222).

Is there a bug or it is a configuration problem I can fix?

Thanks,
Shannon

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Mattias Gaertner
On Wed, 23 Feb 2011 12:26:07 +0800
Xiangrong Fang <[hidden email]> wrote:

> Hi,
>
> While I start lazarus it pops up a box saying:
>
> Package: "LCLBase 1.0"
> Unit Name: "RegisterLCL"
> Unit not found: "RegisterLCL"

The current version is "LCLBase 1.0.1" and it has the unit registerlcl.

 
> This happens on Linux x64 platform and on several recent releases of lazarus
> 0.9.31 (e.g.  svn daily snapshot 20110222).
>
> Is there a bug or it is a configuration problem I can fix?

Maybe you have some old files?

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Xiangrong Fang
Hi Mattias,

I confirm that the file is installed on this path:

/usr/lib/lazarus/0.9.31/lcl/units/x86_64-linux/registerlcl.{o|ppu}

But lazarus still complain that it cannot find that unit on startup.

2011/2/23 Mattias Gaertner <[hidden email]>
On Wed, 23 Feb 2011 12:26:07 +0800
Xiangrong Fang <[hidden email]> wrote:

> Hi,
>
> While I start lazarus it pops up a box saying:
>
> Package: "LCLBase 1.0"
> Unit Name: "RegisterLCL"
> Unit not found: "RegisterLCL"

The current version is "LCLBase 1.0.1" and it has the unit registerlcl.


> This happens on Linux x64 platform and on several recent releases of lazarus
> 0.9.31 (e.g.  svn daily snapshot 20110222).
>
> Is there a bug or it is a configuration problem I can fix?

Maybe you have some old files?

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus


--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Mattias Gaertner

 


Xiangrong Fang <[hidden email]> hat am 23. Februar 2011 um 09:54 geschrieben:

Hi Mattias,
I confirm that the file is installed on this path:
/usr/lib/lazarus/0.9.31/lcl/units/x86_64-linux/registerlcl.{o|ppu}
But lazarus still complain that it cannot find that unit on startup.

 

Check via the Package / Package Graph what lclbase.lpk file is used and if it is 1.0.1.

 

Mattias

 


2011/2/23 Mattias Gaertner <[hidden email]>
On Wed, 23 Feb 2011 12:26:07 +0800
Xiangrong Fang <[hidden email]> wrote:

> Hi,
>
> While I start lazarus it pops up a box saying:
>
> Package: "LCLBase 1.0"
> Unit Name: "RegisterLCL"
> Unit not found: "RegisterLCL"

The current version is "LCLBase 1.0.1" and it has the unit registerlcl.


> This happens on Linux x64 platform and on several recent releases of lazarus
> 0.9.31 (e.g.  svn daily snapshot 20110222).
>
> Is there a bug or it is a configuration problem I can fix?

Maybe you have some old files?

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Xiangrong Fang
Hi Mattias,

LCLBase 1.0, not 1.01, but under that, FCL is at 1.0.1

Sincerely,
Shannon

2011/2/23 Mattias Gaertner <[hidden email]>

 


Xiangrong Fang <[hidden email]> hat am 23. Februar 2011 um 09:54 geschrieben:


Hi Mattias,
I confirm that the file is installed on this path:
/usr/lib/lazarus/0.9.31/lcl/units/x86_64-linux/registerlcl.{o|ppu}
But lazarus still complain that it cannot find that unit on startup.

 

Check via the Package / Package Graph what lclbase.lpk file is used and if it is 1.0.1.

 

Mattias

 


2011/2/23 Mattias Gaertner <[hidden email]>
On Wed, 23 Feb 2011 12:26:07 +0800
Xiangrong Fang <[hidden email]> wrote:

> Hi,
>
> While I start lazarus it pops up a box saying:
>
> Package: "LCLBase 1.0"
> Unit Name: "RegisterLCL"
> Unit not found: "RegisterLCL"

The current version is "LCLBase 1.0.1" and it has the unit registerlcl.


> This happens on Linux x64 platform and on several recent releases of lazarus
> 0.9.31 (e.g.  svn daily snapshot 20110222).
>
> Is there a bug or it is a configuration problem I can fix?

Maybe you have some old files?

Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus



--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Mattias Gaertner

 


Xiangrong Fang <[hidden email]> hat am 23. Februar 2011 um 11:42 geschrieben:

LCLBase 1.0, not 1.01, but under that, FCL is at 1.0.1

 

Check via the Package / Package Graph what lclbase.lpk file is used and if it is 1.0.1.

 

Maybe you have some old files?

You have some old files.
Please update.
Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] startup problem

Xiangrong Fang
Hi Mattias,

The key problem is that I did NOT compile it myself, I downloaded the amd64 deb from the daily snapshot page.  There was no fpc or lazarus on the ubuntu (2 machines) before I install snapshot 20110222.

How do I update individual files? Also, isn't it a bug that the snapshot included some old files?

Sincerely,
Shannon

2011/2/23 Mattias Gaertner <[hidden email]>

 


Xiangrong Fang <[hidden email]> hat am 23. Februar 2011 um 11:42 geschrieben:


LCLBase 1.0, not 1.01, but under that, FCL is at 1.0.1

 

Check via the Package / Package Graph what lclbase.lpk file is used and if it is 1.0.1.

 

Maybe you have some old files?

You have some old files.
Please update.
Mattias

--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus



--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus