[Lazarus] fpc installation error

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two different computers and cannot get the fpc package installed. I have downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and lazarus-project_1.8.2-0_amd64.deb. 

The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have uninstalled previous lazarus versions, and have tried to completely remove all associated files, both using Synaptic Package Manager and also chasing down each file and deleting them. Still, on both machines, when I try to install fpc.3.0.4-2, I get the following error: "errpr: breaks existing package fpc conflict 'fpc()'. On the laptop I even did a complete disc-cleaning installation of linux mint 18.2, and repeated the process. Still get the error.  What do I need to do, now that I have two computers with no operating lazarus versions? 

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list

I had the same problem when I tried to install Lazarus on Ubuntu Mate 18.04.  I ended up installing it using the Synaptic Package Manager because I would get the same error that you got when I tried to install it from either the .deb files or via the regular Ubuntu Software application.  I made sure I had all possible source and binary options selected for installation.  It worked perfectly when I did it that way.  

Hope this helps.

Bye,
Barbara

Barbara M. Harris
[hidden email]
https://www.handknitsbybarbara.com/

"There's no such thing as a normal cat."
On 05/21/2018 11:32 AM, Larry Dalton via Lazarus wrote:
I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two different computers and cannot get the fpc package installed. I have downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and lazarus-project_1.8.2-0_amd64.deb. 

The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have uninstalled previous lazarus versions, and have tried to completely remove all associated files, both using Synaptic Package Manager and also chasing down each file and deleting them. Still, on both machines, when I try to install fpc.3.0.4-2, I get the following error: "errpr: breaks existing package fpc conflict 'fpc()'. On the laptop I even did a complete disc-cleaning installation of linux mint 18.2, and repeated the process. Still get the error.  What do I need to do, now that I have two computers with no operating lazarus versions? 




--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
I am definitely not a linux expert. Where do I get all the packages that I need to install this version of lazarus?



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Barbara M. Harris-Pruitt via Lazarus" <[hidden email]>
Date: 5/21/18 11:48 (GMT-05:00)
To: Larry Dalton via Lazarus <[hidden email]>
Cc: "Barbara M. Harris-Pruitt" <[hidden email]>
Subject: Re: [Lazarus] fpc installation error

I had the same problem when I tried to install Lazarus on Ubuntu Mate 18.04.  I ended up installing it using the Synaptic Package Manager because I would get the same error that you got when I tried to install it from either the .deb files or via the regular Ubuntu Software application.  I made sure I had all possible source and binary options selected for installation.  It worked perfectly when I did it that way.  

Hope this helps.

Bye,
Barbara

Barbara M. Harris
[hidden email]
https://www.handknitsbybarbara.com/

"There's no such thing as a normal cat."
On 05/21/2018 11:32 AM, Larry Dalton via Lazarus wrote:
I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two different computers and cannot get the fpc package installed. I have downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and lazarus-project_1.8.2-0_amd64.deb. 

The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have uninstalled previous lazarus versions, and have tried to completely remove all associated files, both using Synaptic Package Manager and also chasing down each file and deleting them. Still, on both machines, when I try to install fpc.3.0.4-2, I get the following error: "errpr: breaks existing package fpc conflict 'fpc()'. On the laptop I even did a complete disc-cleaning installation of linux mint 18.2, and repeated the process. Still get the error.  What do I need to do, now that I have two computers with no operating lazarus versions? 




--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
In reply to this post by Free Pascal - Lazarus mailing list
I am definitely not a linux expert. Where do I get all the packages that I need to install this version of lazarus?



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Barbara M. Harris-Pruitt via Lazarus" <[hidden email]>
Date: 5/21/18 11:48 (GMT-05:00)
To: Larry Dalton via Lazarus <[hidden email]>
Cc: "Barbara M. Harris-Pruitt" <[hidden email]>
Subject: Re: [Lazarus] fpc installation error

I had the same problem when I tried to install Lazarus on Ubuntu Mate 18.04.  I ended up installing it using the Synaptic Package Manager because I would get the same error that you got when I tried to install it from either the .deb files or via the regular Ubuntu Software application.  I made sure I had all possible source and binary options selected for installation.  It worked perfectly when I did it that way.  

Hope this helps.

Bye,
Barbara

Barbara M. Harris
[hidden email]
https://www.handknitsbybarbara.com/

"There's no such thing as a normal cat."
On 05/21/2018 11:32 AM, Larry Dalton via Lazarus wrote:
I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two different computers and cannot get the fpc package installed. I have downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and lazarus-project_1.8.2-0_amd64.deb. 

The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have uninstalled previous lazarus versions, and have tried to completely remove all associated files, both using Synaptic Package Manager and also chasing down each file and deleting them. Still, on both machines, when I try to install fpc.3.0.4-2, I get the following error: "errpr: breaks existing package fpc conflict 'fpc()'. On the laptop I even did a complete disc-cleaning installation of linux mint 18.2, and repeated the process. Still get the error.  What do I need to do, now that I have two computers with no operating lazarus versions? 




--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
In reply to this post by Free Pascal - Lazarus mailing list
Op 21-05-18 om 17:48 schreef Barbara M. Harris-Pruitt via Lazarus:
> I had the same problem when I tried to install Lazarus on Ubuntu Mate
> 18.04.  I ended up installing it using the Synaptic Package Manager
> because I would get the same error that you got when I tried to install
> it from either the .deb files or via the regular Ubuntu Software
> application.  I made sure I had all possible source and binary options
> selected for installation.  It worked perfectly when I did it that way.

Better file a bug report on Linux Mint or Ubuntu, then.

Regards,

Joost
--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
In reply to this post by Free Pascal - Lazarus mailing list
On Mon, 21 May 2018 11:32:26 -0400
Larry Dalton via Lazarus <[hidden email]> wrote:

> I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two
> different computers and cannot get the fpc package installed. I have
> downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and
> lazarus-project_1.8.2-0_amd64.deb.
>
> The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have
> uninstalled previous lazarus versions, and have tried to completely remove
> all associated files, both using Synaptic Package Manager and also chasing
> down each file and deleting them. Still, on both machines, when I try to
> install fpc.3.0.4-2, I get the following error: "errpr: breaks existing
> package fpc conflict 'fpc()'.

You can ignore that error message.
Proceed to install the lazarus deb.

I will see if I can create a fpc deb without that error.

Mattias
--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] fpc installation error

Free Pascal - Lazarus mailing list
Thanks, Mattias!



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Mattias Gaertner via Lazarus <[hidden email]>
Date: 5/21/18 14:07 (GMT-05:00)
Cc: Mattias Gaertner <[hidden email]>
Subject: Re: [Lazarus] fpc installation error

On Mon, 21 May 2018 11:32:26 -0400
Larry Dalton via Lazarus <[hidden email]> wrote:

> I have been trying to upgrade to Lazarus 1.8.2.-0_amd64.deb on two
> different computers and cannot get the fpc package installed. I have
> downloaded fpc_3.0.4-2_amd64.deb, fpc-src_3.0.4-2_amd64.deb, and
> lazarus-project_1.8.2-0_amd64.deb.
>
> The laptop has Linux Mint 18.2, and the desktop has Linux 17.2. I have
> uninstalled previous lazarus versions, and have tried to completely remove
> all associated files, both using Synaptic Package Manager and also chasing
> down each file and deleting them. Still, on both machines, when I try to
> install fpc.3.0.4-2, I get the following error: "errpr: breaks existing
> package fpc conflict 'fpc()'.

You can ignore that error message.
Proceed to install the lazarus deb.

I will see if I can create a fpc deb without that error.

Mattias
--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus