[Lazarus] Trouble building IDE using lazbuild

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] Trouble building IDE using lazbuild

shoKwave
Hi list,

since some time (IIRC since making the lcl a usual package) I get an
error when building the IDE using lazbuild.

Errormessage:
...
 >Compiling lazhelpintf.pas
 >Compiling lazlinkedlist.pas
 >Compiling lclmemmanager.pas
 >Compiling lclmessageglue.pas
 >Fatal: Can't find unit Messages used by LCLMessageGlue
 >TExternalToolList.Run Exception:
/home/ingo/dev/lazarus/lcl/lclmessageglue.pas(1,1) Fatal: Can't find
unit Messages used by LCLMessageGlue
 >ERROR: tool reported error

I'm using Ubuntu 10.10 64bit with Gnome(GTK+) FPC 2.5.1 r17306 and
Lazarus 0.9.31 r30265. The commands I use look like this:
 >svn up
 >make clean all
 >./lazbuild -B --pcp=~/dev/lazarus/.lazarus --build-ide=

The make command and rebuilding the IDE from inside the IDE are running
fine. Only lazbuild fails. Also with FPC 2.4.2 and Lazarus 0.9.30 I have
no problems.

Any hints?

--
regards
Ingo




--
_______________________________________________
Lazarus mailing list
[hidden email]
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus