[Lazarus] LCL_FULLVERSION is not recognized

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] LCL_FULLVERSION is not recognized

Free Pascal - Lazarus mailing list
Hi.

I use Lazarus 1.6.4 (temporarely) and lazarus 1.8.4 on Windows 10.
I need to use the LCL version but I can't get it to work properly.
I use the following code:
   {$IFDEF LCL_FULLVERSION > 1080000}
   {$ELSE}
   {$ENDIF}
Compiling the program give me the message Warning include environment
"LCL_FULLVERSION" not found in environment. But this is the way I fount
on the lazarus forum.
What am I doing wrong? And where can I find a list of all Lazarus
environment variables?

--
mvg
Frans van Leeuwen
M 06-51695390


---
Deze e-mail is gecontroleerd op virussen door AVG.
http://www.avg.com

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] LCL_FULLVERSION is not recognized

Free Pascal - Lazarus mailing list
On 12-07-2018 12:51, frans via Lazarus wrote:
I use Lazarus 1.6.4 (temporarely) and lazarus 1.8.4 on Windows 10.
I need to use the LCL version but I can't get it to work properly.
I use the following code:
  {$IFDEF LCL_FULLVERSION > 1080000}
  {$ELSE}
  {$ENDIF}
Compiling the program give me the message Warning include environment "LCL_FULLVERSION" not found in environment. But this is the way I fount on the lazarus forum.
What am I doing wrong? And where can I find a list of all Lazarus environment variables?

Where did you find this on the forum?
Because you shouldn't use {$IFDEF } but {$IF } (because you are using an expression)

So:
{$IF LCL_FULLVERSION > 1080000}
{$ELSE}
{$ENDIF}

If you use {$IFDEF it will check if "LCL_FULLVERSION > 1080000" is defined, which it isn't.

Also see http://www.math.uni-leipzig.de/pool/tuts/FreePascal/prog/node4.html

B.T.W. You need to include "uses lclversion" because LCL_FULLVERSION is declared there (otherwise you get a ansistring error message).

Some other constants: http://lazarus-ccr.sourceforge.net/docs/lcl/lclversion/index-2.html

Grtz,
Rik


--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] LCL_FULLVERSION is not recognized

Free Pascal - Lazarus mailing list
It works, Thx
mvg
Frans van Leeuwen
M 06-51695390
Op 12-7-2018 om 13:43 schreef Rik van Kekem via Lazarus:
On 12-07-2018 12:51, frans via Lazarus wrote:
I use Lazarus 1.6.4 (temporarely) and lazarus 1.8.4 on Windows 10.
I need to use the LCL version but I can't get it to work properly.
I use the following code:
  {$IFDEF LCL_FULLVERSION > 1080000}
  {$ELSE}
  {$ENDIF}
Compiling the program give me the message Warning include environment "LCL_FULLVERSION" not found in environment. But this is the way I fount on the lazarus forum.
What am I doing wrong? And where can I find a list of all Lazarus environment variables?

Where did you find this on the forum?
Because you shouldn't use {$IFDEF } but {$IF } (because you are using an expression)

So:
{$IF LCL_FULLVERSION > 1080000}
{$ELSE}
{$ENDIF}

If you use {$IFDEF it will check if "LCL_FULLVERSION > 1080000" is defined, which it isn't.

Also see http://www.math.uni-leipzig.de/pool/tuts/FreePascal/prog/node4.html

B.T.W. You need to include "uses lclversion" because LCL_FULLVERSION is declared there (otherwise you get a ansistring error message).

Some other constants: http://lazarus-ccr.sourceforge.net/docs/lcl/lclversion/index-2.html

Grtz,
Rik





Virusvrij. www.avg.com

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus