[Lazarus] Detailed message about "incompatible ppu=..."

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] Detailed message about "incompatible ppu=..."

Free Pascal - Lazarus mailing list
wsgrids.pp(13,30) Fatal: Cannot find WSGrids used by Grids, incompatible
ppu=/home/user/lazarus/lcl/units/x86_64-linux/wsgrids.ppu, package LCLBase

I didn't show that msg before, now I see it and show it. Can Laz show
more detailed error here? with ppu version and platform?

--
Regards,
Alexey

--
_______________________________________________
lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Detailed message about "incompatible ppu=..."

Free Pascal - Lazarus mailing list
On Sat, 11 May 2019 13:06:19 +0300
AlexeyT via lazarus <[hidden email]> wrote:

> wsgrids.pp(13,30) Fatal: Cannot find WSGrids used by Grids,
> incompatible
> ppu=/home/user/lazarus/lcl/units/x86_64-linux/wsgrids.ppu, package
> LCLBase

When the compiler gives "Cannot find A used by B", the IDE checks what
pas/pp/ppu files are in the search path, and if there is a ppu file it
inserts "incompatible ppu=filename, package".


> I didn't show that msg before, now I see it and show it. Can Laz show
> more detailed error here? with ppu version and platform?

The platform is probably x86_64-linux, unless you did something really
stupid.
The exact ppu "version" is never useful for the user.
The important information is that fpc cannot use this ppu. Either
because
- it was compiled with another fpc version
- or it was compiled with (depends on) some other ppu files,
  that are not in the search path.
- or you misconfigured some search paths.

Have you tried to compile clean?

Mattias

--
_______________________________________________
lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Detailed message about "incompatible ppu=..."

Free Pascal - Lazarus mailing list
> Have you tried to compile clean?

I tried, yes. It didn't help, same error. What helped: i updated date
stamp of WSGrids.pas (touch).

--
Regards,
Alexey

--
_______________________________________________
lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus