[Lazarus] Cannot compile app for Qt5 on Ubuntu 19.4 now

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] Cannot compile app for Qt5 on Ubuntu 19.4 now

Free Pascal - Lazarus mailing list
Compile Project, Mode: linux x32 qt5, CPU: i386, Target:
builds/linux-x32-qt5/cudatext: Exit code 1, Errors: 3
Error:
/home/user/fpcupdeluxe/lazarus/lcl/units/i386-linux/qt5/qtwidgets.o: In
function `TQTABSTRACTSPINBOX__SETVALUE':
Error:
/home/user/fpcupdeluxe/lazarus/lcl/interfaces/./qt5/qtwidgets.pas:(.text.n_qtwidgets$_$tqttextedit_$__$$_settexthint$ansistring+0x7b):
undefined reference to `QTextEdit_setPlaceholderText'
cudatext.lpr(37,1) Error: Error while linking

Error shows on PC which compiled CudaText for qt5 before, maybe some
library is broken in OS? Updates are fresh, libqt5pas-dev is here.
Ubuntu 19.4 x64.

--
Regards,
Alexey

--
_______________________________________________
lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] Cannot compile app for Qt5 on Ubuntu 19.4 now

Free Pascal - Lazarus mailing list
Problem solved: reason is too old libqt5pas-dev in Ubuntu 19.4 (19.10 is
ok).

AT

--
_______________________________________________
lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus