[Lazarus] 64 bit Cocoa package (Mac)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Lazarus] 64 bit Cocoa package (Mac)

Free Pascal - Lazarus mailing list
I’ve been tasked to make a Lazarus package but I’m stuck in a loop trying to install it. Please note this is my first time using Lazarus.

I’m able to create and compile the package but when I try to install (“save and rebuild IDE") it I’m stuck in a loop:

1) by setting the Tools > Options compiler path to ppc386 I can rebuild but I get symbol not found error because the framework I’m linking is 64 bit only.
1) If I set the compiler to ppcx64 I get the "Identifier not found “ATSUFindFontFromName”” error and never get to the building of the actual package.

How can I get out of this loop? Apparently lazarus needs to compile the package and link everything but the IDE also demands I only build with the i386 compiler.

Regards,
        Ryan Joseph

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] 64 bit Cocoa package (Mac)

Free Pascal - Lazarus mailing list
On Sun, Jun 24, 2018 at 12:49 AM, Ryan Joseph via Lazarus <[hidden email]> wrote:
1) by setting the Tools > Options compiler path to ppc386 I can rebuild but I get symbol not found error because the framework I’m linking is 64 bit only.
1) If I set the compiler to ppcx64 I get the "Identifier not found “ATSUFindFontFromName”” error and never get to the building of the actual package.

How can I get out of this loop? Apparently lazarus needs to compile the package and link everything but the IDE also demands I only build with the i386 compiler. 

It's not IDE that demands the compiler to be i386, but the widgetset (Carbon).

You need to specify Lazarus to build for Cocoa instead. In this case you should be able to install the package into IDE.

thanks,
Dmitry

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] 64 bit Cocoa package (Mac)

Free Pascal - Lazarus mailing list


> On Jun 25, 2018, at 9:38 AM, Dmitry Boyarintsev via Lazarus <[hidden email]> wrote:
>
> It's not IDE that demands the compiler to be i386, but the widgetset (Carbon).
>
> You need to specify Lazarus to build for Cocoa instead. In this case you should be able to install the package into IDE.

Yes I finally got it figured out with help from another person. It was the “Tools -> Configure …” settings I was missing.

When I turn on the Cocoa widget set I can install the package now but the IDE is basically broken. Menu items are missing, command key are wrong , size of the controls are all wrong (due to high resolution) and crashing in the source editor amongst others.

Is the IDE broken for the Cocoa widget set?

Regards,
        Ryan Joseph

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus
Reply | Threaded
Open this post in threaded view
|

Re: [Lazarus] 64 bit Cocoa package (Mac)

Free Pascal - Lazarus mailing list


On Sunday, June 24, 2018, Ryan Joseph via Lazarus <[hidden email]> wrote:

Is the IDE broken for the Cocoa widget set?
I prefer the word “incomplete” for Cocoa widget.
Are you using trunk for Lazarus, or an earlier release?

If an earlier release then it’s expected.
If trunk then a screenshot would worth a thousand words.

Thanks,
Dmitry
 

--
_______________________________________________
Lazarus mailing list
[hidden email]
https://lists.lazarus-ide.org/listinfo/lazarus